create chart from external application


I would like to know if this is possible....

I have an application that contains an hierarchical chart.

I would like to export this data into a format that Visio can *understand*,
and then import it into Visio and have it display in a hierarchical manner.

Does any body know if this is possible to do.

.....or, if there is another way of getting my data into Visio, can you
please let me know.


7/1/2003, 4:31:35 AM

1 replies

Here is an article that describes how to automate the org chart wizard, and
how to format your data:

Hope this helps,

Bill K.
Microsoft Corporation

This posting is provided "AS IS" with no warranties, and confers no rights.

"Disco" <d***********> wrote in message
> John Marshall, MVP wrote:
> > If the hierarchical chart can be described as an Org Chart, you can
> > use the OrgChart wizard and replace the standard OrgChart shapes with
> > the ones you need.
> >
> Thanks John,
> Yes. It is an Org Chart.
> Is is posible to do this....
> 1. Generate the formatted export file from ApplicationA
> 2. From ApplicationA, open Visio.
> 3. Once Visio is open, import the Export file that was created.
> So, basically, from my ApplicationA, I want click a button, and display
> Org Chart in Visio.
> Thanks

Bill K. [MSFT]
7/3/2003, 9:36:55 PM

"application has failed to start because the application configura
Entourage application has disappeared
Re: The message filter indicated that the application is busy
Application popup: EXCEL.EXE - Application Error
Calling BTS resource from .Net Application
application needs to be installed
Re: How do I make Office look like a normal application?
why are all my office applications locking up?
SUS blocks ASP.NET application
"Cannot start the source application for this object" for .PDF (ex
can't open application
MS Office Document Scanning .tif won't import to Office Applications
Reference Web Application in Windows Application
Application.OnTime every Y sec with Y NON integer?
Dr.Watson Application Error
Cannot open publisher document using Application.Open
opening file creates high CPU load and application hangs
Excel.exe is not a valid Win32 Application.
Trouble deploying smart device application from Studio.NET 2003
Client Application Installer
Losing view of a label and box when changing their width property on Form On_Open event in Access 2003 application.
VS.NET application security when starting Application from network
[ANN] Quit all Microsoft applications before backing up
Pivot Chart using in a ASP.Net Application
Excel.exe - Application error; access violation
Transfer of Application
PHOTOED.EXE - Application Error
Application error
Office 2007 Application pane remains transparent after coming up
OT: Application can not access internet
Office 2004 issue with documents NOT BEING ABLE TO OPEN APPLICATION, but application can open documents.
Open Outlook from another application, A Suspicious Script ...
Web application calling Excel 2003
Had B2TR -- everything was peachy until Saturday (1/13/07) Suddenly, on trying to open any Office program or OneNote, I get: "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem." Reinstalling B2TR did not fix it. Decided to uninstall B2TR and downloaded trial version of Office & OneNote. All of a sudden got error msgs from .NET framework (??): "Error 25007.Error occurred while initializing fusion. Setup could not load fusion with LoadLibraryShim(). Error: The handle is invalid." Uninstalled absolutely everything that had anything to do with .NET framework or Office at all. Install of trial version finally successful (it says it has been successfully installed) Try to run any of the Office or OneNote trial version programs I get same error: "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem." I have tried googling this error, searching KB, product support, these communities -- absolutely zero matches for anything like this. Frustrated is my middle name at the moment. I don't know what to try next -- can't figure out where this is coming from. Please help. Right now I'm having to use my husband's work laptop just to read Word docs attached to my emails.

Entourage application has disappeared
0 replies , 10/8/2003, 8:02:34 AM
Recently switched to OSX after using OS9 on my imac since I bought it. I opened the launcher in Classic mode and clicked on the Alias for Entourage. It said it did not exist. It has disappeared from its normal place in Microsoft Office folder. I have looked everywhere for it, but to no avail. Now it says it is being used by the system software and cannot be opened. I am getting calendar reminders in OSX. How can I find it? I do not have the original software. It was installed at Arizona State University and I now live in Denmark. I need my addresses. If I cannot find it, is there a way to access the data folders? Hjelp!

Application popup: EXCEL.EXE - Application Error
1 replies , 1/8/2004, 5:52:29 PM
Does anyone have a possible solution for this problem: Application popup: EXCEL.EXE - Application Error : The instruction at "0x30d29592" referenced memory at "0x00800cfc". The memory could not be "read".

R Dubbs
Calling BTS resource from .Net Application
2 replies , 5/1/2006, 4:26:02 PM
Hi, I need to integrate .Net application with BizTalk. At BizTalk end i have a "Receive Port" of type "Request-Response". Can anyone tell me how to post / submit an XML request to this existing "Receive Port" from a .Net Application. I want to do this syncronously. Can anyone suggest me an approch? Regards, Jay Kinker__

application needs to be installed
0 replies , 9/12/2003, 8:32:44 PM
I have installed Office on a Windows 2000 machine. Under the administrator profile, all is well, but as soon as I log in as a domain user, I recieve an error that the application needs to be installed. Under programs, all of the programs are listed, but with genric icons. I insert the Office disk, install runs and everything is fine. After a reboot, the conditions return to "application needs to be installed". Please advise. Jeremy

J Kaikko
why are all my office applications locking up?
3 replies , 8/26/2005, 7:25:01 AM
hi, i've had my office 2k3 for a year now, i bought a separate CD. recently, my computer crashed and i had to reboot completely. i reinstalled office fine, yet when i open any office application, it starts normally and a second after opening it, every single button or command option goes opaque and unusable, in EVERY application! i've run all the updates and it's completely virus free, so someone PLEASE help me!

SUS blocks ASP.NET application
3 replies , 2/12/2004, 2:44:19 PM
I have installed Microsoft SUS. Part of the installation included IIS lockdown. This has disabled an ASP.NET application running on the server. after some searching I have been able to reverse IIS lockdown. Is there some way to enable the application rather than just undo IIS lockdown Richard

Richard Prossor
Hello, I have a user who is running Windows XP SP2 and office 2003 sp2. He has been inseting .pdf obects in to his excel spread sheets (shown as an icon) and this has been functioning fine until recently. Now when he does this he gets the error message "cannot start the source application for this object". Thinking it was his machine i tried it on mine and recieved the same error. I tried it with a word document and it opened right up. I tried the suggestion that was posted on 5/24/06 with a similar subect title but that did not help. i have searched microsoft, google, yahoo and the forum with so successful solution. Anyone have any ideas?? Please, thanks Derek

can't open application
5 replies , 11/14/2006, 3:28:01 AM
Hi, I was wondering if i may get some help here. At first, i have a few computers connected to the network (say comp1, comp2, and comp3). I have one application document sit on one of the computers. It's Access file (.mdb). Now, i don't know if this is to do with the computers or what. I can open it using comp1 while the application is being used FIRST by comp2. Then, I tried to open it again using comp3 by just double-clicking it. Nothing happen. No error message or warning what soever. I don't know why i could double-click it to open it with comp1. I just did in the same way as i did with comp1. I understand that we should not open the used or open application. But usually it would allow you to open it with some warning pop-up message. Is it to do with how i installed the office 2003? Thank you in advance

I scan files using MS Office Document Scanning in Office XP which are saved as .tif. Trying to open those files in Word, PowerPoint, PhotoEditor results in invalid file header errors. MODS doesn't offer another scanning option. I want to crop some of the scans. How?

Scott Scott
Reference Web Application in Windows Application
0 replies , 12/23/2005, 3:06:02 PM
I have a web application written in 2005 that I would like to reference in a windows application written in Any suggestions as to how i can do this? -- Live long, stay strong

Application.OnTime every Y sec with Y NON integer?
4 replies , 12/10/2007, 11:35:24 AM
Dear all, my question is about the Application.OnTime Method. Usually I use it after having these two variables defined: Public RunWhen As Double Public Const cRunIntervalSeconds = X then the operation/procedure to be scheduled starts periodically when: RunWhen = Now + TimeSerial(0, 0, cRunIntervalSeconds) Doing so, I can schedule my macros every X seconds where X is an integer. Now I wonder whether is possible scheduling event every Y seconds with Y decimal (e.g.: 1.2 s, 4.5 s ...). Any suggestion? BR, CR

Dr.Watson Application Error
0 replies , 9/23/2004, 12:31:12 PM
In our Organization excell2000 is installed on windowsNT4 work stationa nd its giving DR.watson error in following manner An Application error has occured and an application log is being created. Exception :Acees violation (0*00000005) \ Adress: 0*300226d69 I cant upgrade to wimdows2000 due to hardware availability. Any suggestions please thanks

Cannot open publisher document using Application.Open
0 replies , 12/3/2009, 10:48:01 AM
Hi All, I'm receiving error message "Publisher has detected a problem in the file you are trying to open. To protect your computer, Publisher will not open the file." when attempting to open a publisher document. Here is what the code looks like... Application publisherApplication = null; Document document = null; Try { publisherApplication = new Application(); document = publisherApplication.Open(this.File.FullName, true, false, PbSaveOptions.pbDoNotSaveChanges); } Finally { // Release COM objects } The message is appearing when I call Open. Sometimes it manages to open the document and I can always open the document in publisher, although there was one occasion when I received the message when opening another document in publisher. This issue occurs on different documents so cannot be down to the document being corrupt. I have Office 2007 SP2 running on Windows 7 (RC) and I'm using the Microsoft.Office.Interop.Publisher (v 12) assembly. I have searched the knowledge base and tried adding the PromptForBadFiles sub key with a hex value of 1 under HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Publisher. I then received a different error (Exception from HRESULT: 0x80FF000D). I have also tried the hot fix located at and still cannot open the document. Has anyone encountered this issue before and found a solution or workaround? Regards, Jason

Hi there,<br> <br> I've had to force quit the excel program a few times now. every time I start excel it attempts to load all the files that failed to load then the CPU goes high and the application hangs. there appears to be no simple way out of this loop. please help.<br> <br> cheers,<br> <br> Noah

Excel.exe is not a valid Win32 Application.
10 replies , 5/13/2008, 7:38:02 PM
My system: Vista Business 32bit with SP1, Office 2007 Professional with SP1. For a while I was running Vista (without SP1) and using Office 2007 with SP1. Rarely any issues. Sometime after installing Vista SP1, I've been having odd issues with my Office installation, Excel especially. I don't know if it's its SP1 related, or if it's just something went wrong with the Office install. Here's the issue. I leave my PC on 24/7 and simply lock it when I leave the office. After several days, Excel will just stop working, completely. When I try to launch excel I get the error "Excel.exe is not a valid Win32 application". I have tried reapplying SP1. After reapplying the SP1 and rebooting, everything returned to normal. So I thought. A week or so later, same issue. It turns out simply rebooting resolves the issue temporarily. I thought my Excel exe was corrupted (i.e. some file wrote/deleted information from the binary file). I verified modified dates with other excel exe's and everything is the same. Nothing seems out of the ordinary. I can't find any relevant errors in my event log. I can't see anything out of the ordinary when using SysInternal's process monitor either. It's like something in Vista thinks this EXE is a bad EXE and it won't let it launch until I reboot. I have even noticed after several times of launching the exe, if I browsed to the installation directory, the actual icon for Excel was dimmed, as if it was like a hidden file or something. WTH? When I rebooted, it returned to the normal icon. I have yet to see the icon dim again, even during times of issue. I disabled my antivirus thinking it was the culprit to no avail. What in the world could be happening? When I use the process monitor, the exe never even gets executed (i.e. no events for excel.exe). Please help!!! -Matthew

Hi, Visual Studio has been giving me major headaches with regard to deploying smart device applications after building onto a PocketPC. I have activeSync 3.5 installed. My device is plugged in and has a guest association on ActiveSync. ActiveSync has recognised the device. Now when I build a project and deploy it... it gives me the following error: ------ Deploy started: Project: blahblah Configuration: Debug Pocket PC ------ Deploying to Pocket PC Device using TCP Connect Transport Error: Cannot establish a connection. Be sure the device is physically connected to the development computer. Seems like quite a troublesome issue! The first time I used a PDA on my machine, it used to work. After moving the device around I started getting this error. Can someone tell me what to do? Contacting Microsoft support was of no help

Shripal Meghani
Client Application Installer
2 replies , 11/26/2003, 4:25:16 AM
Hi all, set up client computers in the To Do list not knowing that XP clients & applications had to be done manually. After manually installing required applications on XP clients manually, every time the user logs on the SBS client installer runs asking whether to install applications on client computer (which it says it can't as user not administrator) or Postpone. How do i stop this Installer running everytime a user logs on? Thanks, Gary

Have a box for background color, formatted to the Back in Design View, and several labels on top of it in the Header section. The last two columns are not visible unless a specific type of data is present. Works fine but I'd like to make the box and the title label smaller in Design View so that there isn't a lot of blank background color showing when those columns aren't needed. It would just make the form look a little neater, sized to the column labels present, instead of the big blank unused space. Set the width property of the box and title label controls to a smaller size in Design View. Change the Width property to a larger size for each in the Form Open event when the data is present. The problem is that the box and title label no longer show on the form at all. The unmodified column title labels that should be in front of the box are still there just no colored background and not title label. I've tried using RunCommand acCmdSendToBack but that is not available in the Form View, didn't think it would be but tried anyway. I've looked at several of the DoCmd methods, e.g. DoMenuItem, but if any of these or the RunCommand methods apply I've been unable to get them to work. Any help would be appreciated.

0 replies , 4/25/2006, 6:17:01 AM
I need an application which got input into tables (string and picture) and i can design the way the layout of that input should be. today i use excel - i build tables whish i print after i got all the data on it. because i have to use it for more than one user and i dont want to but many lisences i want to use an applicrion for that. is anyone have an idea waht application can support me ?

Hello folks following situation: - we built an application (windows application) with VS.NET 2005/VB.NET - Application does: - collect inventory (Win32Product and Win32QuickFixEngineering) information using WMI (System.Management) - reads/writes a registry key for a UID (to identify the device) - connects to a central SQL Server and submit the collected inventory information The application must be started from a Network (UNC) Path.. usually this will be the Netlogon Share, using a Logon Script. The challenge (problem) we've faced is .NET Security. We do NOT want to deploy the application using ClickOnceDeploy, nor we want to install a Security template or something simliar. do we really have to call caspol.exe in the login script to manage the code access security ? or how can we 'sign' or authorize the .NET App to run from a network share? we already thought about going down to vb6/vc6 to get rid off that problem. (application runs smooth when started locally..) what we get when we start the App is: --- System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.RegistryPermission, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed. at System.Security.CodeAccessSecurityEngine.Check(Object demand, StackCrawlMark& stackMark, Boolean isPermSet) at System.Security.CodeAccessPermission.Demand() at Microsoft.Win32.RegistryKey.CheckSubKeyReadPermission(String subkeyName) at Microsoft.Win32.RegistryKey.CheckOpenSubKeyPermission(String subkeyName, Boolean subKeyWritable) at Microsoft.Win32.RegistryKey.OpenSubKey(String name, Boolean writable) at cxnInvColWorker.basRegistry.RegistryGetValue(String sKey, String sValue, String sDefaultValue) at cxnInvColWorker.formMain.formMain_Load(Object sender, EventArgs e) .. .. The action that failed was: Demand The type of the first permission that failed was: System.Security.Permissions.RegistryPermission The Zone of the assembly that failed was: Intranet --- ************** Exception Text ************** System.Security.SecurityException: That assembly does not allow partially trusted callers. at System.Security.CodeAccessSecurityEngine.ThrowSecurityException(Assembly asm, PermissionSet granted, PermissionSet refused, RuntimeMethodHandle rmh, SecurityAction action, Object demand, IPermission permThatFailed) at cxnInvColWorker.formMain.btnSWInv_Click(Object sender, EventArgs e) at System.Windows.Forms.Control.OnClick(EventArgs e) at System.Windows.Forms.Button.OnClick(EventArgs e) at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent) at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks) at System.Windows.Forms.Control.WndProc(Message& m) at System.Windows.Forms.ButtonBase.WndProc(Message& m) at System.Windows.Forms.Button.WndProc(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) The action that failed was: LinkDemand The Zone of the assembly that failed was: Intranet --- can someone point me in a direction? helps really appreciated! Christian

Christian Muggli
This article adds new information that is necessary for a good backup of your Identity. Anything that interacts with the Entourage database needs to be quit in order to back-up the database. This means all Office applications and helper applications. Continue reading for details and solutions to make your backup successful. Quit all Microsoft applications before backing up (The Entourage Help Blog) <> If you use SuperDuper Backup software, you can use a shell script to quit all applications in SuperDuper. The link to download the script is in the article. Directions on using script with SuperDuper can be found here: Backup Entourage with SuperDuper! (The Entourage Help Blog) <> -- Diane Ross, Microsoft Mac MVP Entourage Help Page <> Entourage Help Blog <>

Diane Ross
Pivot Chart using in a ASP.Net Application
1 replies , 6/30/2005, 10:28:08 AM
Hi newsgroup, i want to create a website with I want present on this site a dynamical Pivot chart, which get his datas from a MS SQL server. The are a lot of datas in the database(at least 31.000.000 rows per year). I could not make smaller the databse because the customer should view the details (Year/Quarter/Month/Week/Day/Hour/Minute/Second=60*60*24*365= 31.536.000 If a customer uses the Pivot-chart(with drag and drop the fields),all the asked datas will send from the Server to the Client to create the new Pivot-Chart-image. But there is a high transfer. The Question: Is it possible, that the datas stay on the server and the server creates the new image ?( send only the image do not send the whole datas). But it should be a dynamical Pivot-Chart with the possibility to drag and drop the fields. regards from Germany Sefer

sefer derya
1 replies , 4/23/2005, 9:31:04 AM
i just want to follow up my application

Transfer of Application
2 replies , 12/11/2006, 4:30:00 AM
What has to be done to transfer the Microsoft Office applications to a new PC? Both are Windows XP Professional SP2, but my "old" PC is about to crash and I have a new PC on order. -- Jeff

PHOTOED.EXE - Application Error
2 replies , 10/14/2007, 9:05:00 PM
Hi, Today I went to print an image ( a saved JPEG file) in Photo Editor 3.01 and I received a pop up box stating: The instruction at "0x0012f122" referenced memory at "0x00000000" The memory could not be "written" I have never see this before and cannot print ANY image that is opened with this program. I searched and searched for that error code but couldn't find it. I'm running 2000 pro and have it updated as of today. Can someone please help me fix this or suggest another good quality program that I may replace this with. Thank you for helping.

Application error
3 replies , 3/16/2005, 7:31:05 PM
the instruction at 0x302921AF referenced memory at 0x00640040, the memory could not be read. CEO of the company is taking a single spreadsheet, right clicking on the bottom and copying the intial spread to make 4 addtional tabs at the bottom and adding data and then saving. he tried to save along the way several times with no issue, but when he gets so far on the 5th says it cant save and gives the above error message. he has latest of the Service packs for windows and Office. Any help would be great

I installed Office Enterprise 2007, updating my Office 2003. Now when I open an application (excel or word, for example) the pane remains transparent. Clicking on the top bar to activate the window pane, it still remains transparent. My system has Windows XP MCE 2002 os, 512MB RAM, P4 2.4GHz processor. I did not have a problem with Office 2003. I updated my ATI graphics driver, turned off "transparent while dragging" windows options. Nothing seems to help.

OT: Application can not access internet
5 replies , 9/30/2003, 6:26:24 PM
Hi This is slightly off-topic. I have an ms access app that posts data to a website using the internet transfer control. I have tested it on my sbs2000 server (literally) which also has ISA Server, and it works fine. Now I take it to client site and it can not post to the site via their ISA Server/sbs2000 both with pretty much the standard configuration. Client's internet access is otherwise fine for browsing the internet etc using the ISA/Proxy Server. Is there a reason that an app can access post data while on an sbs2000 server but won't from a client PC? Can I do something on the client's server to make it friendlier to the access app? Is there a way to check where things are going wrong? Thanks Regards

BACKGROUND: Just migrated all my files and apps from a G4-400 to a new Mac Mini 1.87ghz Intel running pre-installed OSX10.4.10. Used CD to install 'normal' version of Office 2004 Mac on the new Mac Mini. In fact its the same disk that I used originally to install Office on the G4-400. PROBLEM: Neither old .xls and .doc documents (made on old Mac, nor new .xls and ..doc documents (made on new Mac)will not open their respective applications, EXCEL or WORD, when clicked upon. ADDITIONAL INFO: However, when I use either of the the application's "Open" feature, theres is no problem and all .xls and .doc open and work normally. There was an error code dialog box generated each a document cannot open its application "-60160" , I believe, but I failed to write it down, before I left place where the new Mac is located. Is there an upgrade version to office 2004 Mac that will fix this, or is it something else? Am betting there is a simple fix for this but I can't figure it out. Thanks, John

I am open Outlook from another application, using the following code: Application olApp; olApp.CreateDispatch("Outlook.Application")) _NameSpace olNs(olApp.GetNamespace("MAPI")); COleVariant covOptional((long)DISP_E_PARAMNOTFOUND, VT_ERROR); olNs.Logon(covOptional, covOptional, covOptional, covOptional); But in the line _NameSpace olNs(olApp.GetNamespace("MAPI")); appears a message from McAfee antivirus saying that “A Suspicious Script Has Been Detected” How can I do to avoid this warning? I know that is possible avoid this warning, because I have an application that open Outlook too and don’t appears the warning, but I don’t know how. Thanks & Regards, Rui Oliveira

Web application calling Excel 2003
0 replies , 9/12/2008, 6:52:50 AM
Hello, My Web application in VB2008 with IIS calls Excel (2003) to create an Excel file xls. I use therefore Microsoft.Office.Interop.Excel, version 11. This application does not use anonymous connections; it automaticaly uses the Windows userid. On my development PC, with local server, everything is OK. On a test server with IIS and Excel, my program gets an error on the first statement related to Excel : Dim ApplicationExcel As New Excel.Application Error message: Retrieving the COM class factory for component with CLSID {...} failed due to the following error : 80070005. Explanations : ASP.NET is not authorized to access the requested resource. Etc. What access rights should I grant to what resources ? Thank you for your help, Gilbert

Gilbert Tordeur